Menu
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Facebook profile
Overlord: Fellowship of Evil
Overlord: Fellowship of Evil
Veröffentlichung: 2015. Oktober 20. (PC)
Sys. Reqs.: Low (15)
Popularität: ~2500# ■
Genre: Action, Adventure
Entwickler: Codemasters
Publisher: Codemasters
©© 2015 The Codemasters Software Company Limited (Codemasters). All rights reserved.
iThere are only official system requirements on the site which are released by developers or an official publisher.
Minimale Systemanforderungen:
Empfohlene Systemanforderungen:
CPU:
Intel Core 2 Duo E4600 or AMD Athlon x2 5400+
CPU:
AMD FX Series or Intel Core i5 Series
RAM:
2 GB RAM
RAM:
4 GB RAM
GPU:
AMD HD4870 or Nvidia GTX280
GPU:
AMD R9 270 or Nvidia GTX660
OS:
Windows Vista, Windows 7 or Windows 8 http://systemanforderungen.com/
OS:
Windows Vista, Windows 7 or Windows 8
Store:
4 GB available space
Store:
4 GB available space
Schall:
DirectX Compatible soundcard
Schall:
Direct X compatible soundcard
Netzwerk:
Broadband Internet connection
Comparison:
Compare the system requirements with a configuration added by you.
Ähnliche Produkte:
IraRemember MeDead RealmGhost of a TaleElite Dangerous: HorizonsPrince of Persia: Warrior WithinTomb Raider (2013)Reign Of Kings
Datenbank